Opened 10 years ago

Last modified 10 years ago

#293 reopened Fehler/Defekt

MAC: Alt-Tab doesn't work anymore

Reported by: anonymous Owned by:
Priority: normal Milestone: Neo Version 2.0
Component: Treiber: Mac OS Version: 2.0 Final
Keywords: alt-tab MAC Cc:

Description

In programmes like Opera ALT-TAB, which is used to switch between tabs doesn't work anymore when using neo.keylayout and KeyRemap4MacBook. As soon as switching to normal layout it works fine, as soon as switching back it is just disabled. Any workaround, since not being able to use alt-tab in browsers is a real drawback? Otherwise: Really great work! Appreciating it very much! And except that one problem it runs even better on MAC than it did on my PC before.

Change History (4)

comment:1 by Markus W, 10 years ago

Hey, I just tried to switch TABs in Opera using ALT-TAB and it seems to work fine for me. My configuration is Opera Version 11.61, Mac OS X 10.6.8 and KeyRemap4MacBook 7.5.0.

Regards, Markus

comment:2 by stmayer, 10 years ago

Component: unbekanntTreiber: Mac OS
Resolution: worksforme
Status: newclosed

Can confirm Markus’ observation, works for me, too. Config: Opera 11.61, Mac OS X 10.7.2, KeyRemap4MacBook 7.5.0, neo.keylayout from 2011-09-01.

What versions of the neo.keylayout and KeyRemap4Macbook are you working with?

comment:3 by Arno, 10 years ago

Resolution: worksforme
Status: closedreopened

thank's a lot Markus and stmayer for checking! exactly the same configuration here as stmayer: Opera 11.61, Mac OS X 10.7.2, KeyRemap4MacBook 7.5.0 neo.keylayout has the following date: 17.10.2011, I guess it's the download-date. Filesize is 120.658 bytes...it's the latest version. alt-tab just doesn't work here. ctrl-tab works though, but it switches through tab in order how they are arranged, not in most-recent-used (MRU), like alt-tab should do. If I use alt-tab in any writing application, even in this edit-box here I get this sign: ♫ When I press alt-tab once, the sign appears ♫ underlined or marked, if I press alt-tab again the undelining/marking disappears. If I press alt-tab a third time a second ♫ appears. And so on. I guess this is NOT normal behaviour for alt-tab, isn't it? Does this help in giving a clue where the problem could be? Any ideas or help very much appreciated. :-) Thank's.

best wishes Arno

comment:4 by LarsHuluk@…, 10 years ago

In the last two versions of neo.keylayout alt-tab calls the action "compose" to emulate compose behavior with the limited capabilities of mac layouts. Maybe Opera or the key remapper expect the old alt-tab output. The sign ♫ you are seeing is the compose symbol.

Note: See TracTickets for help on using tickets.