Opened 7 years ago

Last modified 7 years ago

#418 new Fehler/Defekt

Neo2 auf Mac (Yosemite) Mod4 funzt nicht

Reported by: leveleleven@… Owned by:
Priority: normal Milestone:
Component: Treiber: Mac OS Version: 2.0 Final
Keywords: Mod4, Mac, Yosemite Cc: Oliver

Description

Hallo liebe Entwickler,

Ich habe Neo2 nach Anweisung (http://wiki.neo-layout.org/wiki/Neo%20auf%20dem%20Apple%20Macintosh%20einrichten) auf meinem Mac Airbook mit Yosemite installiert. Zum einen heißt KeyRemap4MacBook jetzt Karabiner. Zum anderen finde ich dort keine Einstellung, die irgendwie ähnlich klingt wie »German Neo 2. Enthält:«, so dass ich die nicht anwählen konnte. Auf jeden Fall funktioniert Mod4 nicht und CapsLock über gleichzeitiges Benutzen der beiden Shift-Tasten funzt auch nicht. So kann ich Neo2 nicht voll nutzen, insbesondere dass <>- und #-Taste (in QWERTZ) nicht funktionieren, finde ich schade. <> macht genau das: <> und # ist einfach „leer”.

Was muss man zusätzlich zur Anleitung http://wiki.neo-layout.org/wiki/Neo%20auf%20dem%20Apple%20Macintosh%20einrichten noch beachten? Kann es sein, dass diese Anleitung nicht auf dem aktuellen Stand ist?

Change History (2)

comment:1 by anonymous, 7 years ago

Anleitung definitiv nicht auf dem neusten Stand. Habe die Optionen in Karabiner (in der Anleitung steht ​KeyRemap4MacBook, aber der link stimmt *sig*) nur durch die Suche gefunden.

comment:2 by mrlenat@…, 7 years ago

ok, fix:

zunächst im Karabiner auf misc&uninstall da dann private xml anzeigen oder öffnen drücken. jetzt mit dem editor der Wahl diese anpassen und das was man ursrprünglich als ~/Library/Application Support/KeyRemap4MacBook gespeichert hat

Zusätzlich habe ich noch dem fix in der wiki folgend das hier da reingeschrieben:

<!-- Mod 4 Modifiers and Mod 4 Locks -->

<autogen>--KeyOverlaidModifier-- KeyCode::OPTION_R, ModifierFlag::EXTRA1, KeyCode::VK_MODIFIER_EXTRA1, KeyCode::VK_LOCK_EXTRA1</autogen> <autogen>--KeyToKey-- KeyCode::OPTION_R, KeyCode::VK_MODIFIER_EXTRA1</autogen>

Das kommt dann an die Stelle wo die überschrift <!-- Mod 4 Modifiers and Mod 4 Locks --> schon war. und die 2 Zeilen die da schon stehen mit <autogen .... überschreiben. Traurig aber wahr, so läuft das ganze.

quellen:

der trick lag hier: gute erklärung für das editieren der private.xml:

p.s. alter, euer system behauptet die ganze zeit das sei spam was ich hier abzuschicken versuche... ähm gehts noch? p.p.s: musste alle links entfernen wg akismet ...

Note: See TracTickets for help on using tickets.